use strict;
my $str = 'Shall we meet at, let\'s say, 8:45 AM?';
my $regex = qr/\b\d{1,2}:\d{2}\b|[,.;:?]+|(?:(?!\b\d{1,2}:\d{2}\b)[^\s,.;:?])+/p;
my $subst = '\\n$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";