using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(/accounts-safes-registry/retrieval-api/v1/(ping|password|registry/feedback/|registry/))$";
string input = @"/accounts-safes-registry/retrieval-api/v1/registry/
/accounts-safes-registry/retrieval-api/v1/registry/feedback/
/accounts-safes-registry/retrieval-api/v1/ping
/accounts-safes-registry/retrieval-api/v1/password";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}