package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(/accounts-safes-registry/retrieval-api/v1/(ping|password|registry/feedback/|registry/))$`)
var str = `/accounts-safes-registry/retrieval-api/v1/registry/
/accounts-safes-registry/retrieval-api/v1/registry/feedback/
/accounts-safes-registry/retrieval-api/v1/ping
/accounts-safes-registry/retrieval-api/v1/password`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}