import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(/accounts-safes-registry/retrieval-api/v1/(ping|password|registry/feedback/|registry/))$";
final String string = "/accounts-safes-registry/retrieval-api/v1/registry/\n"
+ "/accounts-safes-registry/retrieval-api/v1/registry/feedback/\n"
+ "/accounts-safes-registry/retrieval-api/v1/ping\n"
+ "/accounts-safes-registry/retrieval-api/v1/password";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}