$re = '/^(/accounts-safes-registry/retrieval-api/v1/(ping|password|registry/feedback/|registry/))$/m';
$str = '/accounts-safes-registry/retrieval-api/v1/registry/
/accounts-safes-registry/retrieval-api/v1/registry/feedback/
/accounts-safes-registry/retrieval-api/v1/ping
/accounts-safes-registry/retrieval-api/v1/password';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);