// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(/accounts-safes-registry/retrieval-api/v1/(ping|password|registry/feedback/|registry/))$").unwrap();
let string = "/accounts-safes-registry/retrieval-api/v1/registry/
/accounts-safes-registry/retrieval-api/v1/registry/feedback/
/accounts-safes-registry/retrieval-api/v1/ping
/accounts-safes-registry/retrieval-api/v1/password";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}