#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^arn:(?P<Partition>[^:\n]*):(?P<Service>[^:\n]*):(?P<Region>[^:\n]*):(?P<AccountID>[^:\n]*):(?P<Ignore>(?P<ResourceType>[^:\/\n]*)[:\/])?(?P<Resource>.*)$"
Local $sString = "# ARN Format Templates" & @CRLF & _
"arn:partition:service:region:account-id:resource" & @CRLF & _
"arn:partition:service:region:account-id:resourcetype:resource" & @CRLF & _
"arn:partition:service:region:account-id:resourcetype/resource" & @CRLF & _
"# Amazon Simple Storage Service (S3)" & @CRLF & _
"arn:aws:s3:::my_corporate_bucket/Development/*" & @CRLF & _
""
Local $sSubst = "Partition: "\1"\nService: "\2"\nRegion: "\3"\nAccountID: "\4"\nResourceType: "\6"\nResource: "\7"\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)