re = /:(ref|doc|term):`([^<`:]+):([^:]+)`/m
str = 'Here are some made up external :ref:`python:references` to the :doc:`python:index` docs and this is an :doc:`internal` reference that isn\'t converted.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end