use strict;
my $str = '\'self\'
sameorigin plus.some.host
';
my $regex = qr/^((?'isolated_keywords'('none')|(deny))|((?'single'(?'just_scheme'[a-z]+\:)|(?'uri'(?'scheme'[a-z]+\:(?'scheme_separator'\/\/)?)?(?'host'[a-z0-9\-*]+\.[a-z0-9\-*.]+)(?'port':[0-9*]+)?)|('self')|(sameorigin))(?'list'((?'list_separator'\ )(?'list_content'(?'just_scheme_in_list'[a-z]+\:)|(?'uri_in_list'(?'scheme_in_list'[a-z]+\:(?'scheme_separator_in_list'\/\/)?)?(?'host_in_list'[a-z0-9\-*]+\.[a-z0-9\-*.]+)?(?'port_in_list':[0-9*]+)?)))+)?))$/mp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}