#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+(?:-\w+)+"
Local $sString = "some number L-BSC-MAP-01 - some other words" & @CRLF & _
"V-A - some other words" & @CRLF & _
"some number L-BFC-MAP-05 some other words - some other words" & @CRLF & _
"some number V-B some other words" & @CRLF & _
"some number L-BFC-MAD-04 some other words"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")