package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+(?:-\w+)+`)
var str = `some number L-BSC-MAP-01 - some other words
V-A - some other words
some number L-BFC-MAP-05 some other words - some other words
some number V-B some other words
some number L-BFC-MAD-04 some other words`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}