import re
regex = re.compile(r"batiment restructur[eé]", flags=re.MULTILINE)
test_str = ("plateaux entièrement rénovés XXXXXX immeuble de style industriel restructuré \n\n"
"surface livrée rénovée et climatisée dans un magnifique immeuble haussmannien restructuré\n\n"
"batiment restructuré XXXXXX plateau livré entièrement rénové et décloisonné \n\n"
"parking exterieur restructuré XXXXX bureau rénové \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")