# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<!--(.*?)-->|\s\B//gm;t' <<< "<body>
<!-- carousel slider section -->
<section id=\"carousel\">
<div class=\"carouserl-item\" id=\"carousel1\">
<!-- gambar pertama -->
<img src=\"img1.jpg\" alt=\"Image Description\" width=\"300\" height=\"600\">
</div>
<div class=\"carouserl-item\" id=\"carousel2\">
<!-- gambar kedua -->
<img src=\"img2.jpg\" alt=\"Image Description\" width=\"300\" height=\"600\">
</div>
</section>
</body>"