package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<!--(.*?)-->|\s\B`)
var str = `<body>
<!-- carousel slider section -->
<section id="carousel">
<div class="carouserl-item" id="carousel1">
<!-- gambar pertama -->
<img src="img1.jpg" alt="Image Description" width="300" height="600">
</div>
<div class="carouserl-item" id="carousel2">
<!-- gambar kedua -->
<img src="img2.jpg" alt="Image Description" width="300" height="600">
</div>
</section>
</body>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}