import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--(.*?)-->|\\s\\B";
final String string = "<body>\n"
+ " <!-- carousel slider section -->\n"
+ " <section id=\"carousel\">\n"
+ " <div class=\"carouserl-item\" id=\"carousel1\">\n"
+ " <!-- gambar pertama -->\n"
+ " <img src=\"img1.jpg\" alt=\"Image Description\" width=\"300\" height=\"600\"> \n"
+ " </div>\n"
+ " <div class=\"carouserl-item\" id=\"carousel2\">\n"
+ " <!-- gambar kedua -->\n"
+ " <img src=\"img2.jpg\" alt=\"Image Description\" width=\"300\" height=\"600\"> \n"
+ " </div>\n"
+ " </section>\n"
+ "</body>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}