# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<!--(.*?)-->|\s\B"
test_str = ("<body>\n"
" <!-- carousel slider section -->\n"
" <section id=\"carousel\">\n"
" <div class=\"carouserl-item\" id=\"carousel1\">\n"
" <!-- gambar pertama -->\n"
" <img src=\"img1.jpg\" alt=\"Image Description\" width=\"300\" height=\"600\"> \n"
" </div>\n"
" <div class=\"carouserl-item\" id=\"carousel2\">\n"
" <!-- gambar kedua -->\n"
" <img src=\"img2.jpg\" alt=\"Image Description\" width=\"300\" height=\"600\"> \n"
" </div>\n"
" </section>\n"
"</body>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.