// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<!--(.*?)-->|\s\B").unwrap();
let string = "<body>
<!-- carousel slider section -->
<section id=\"carousel\">
<div class=\"carouserl-item\" id=\"carousel1\">
<!-- gambar pertama -->
<img src=\"img1.jpg\" alt=\"Image Description\" width=\"300\" height=\"600\">
</div>
<div class=\"carouserl-item\" id=\"carousel2\">
<!-- gambar kedua -->
<img src=\"img2.jpg\" alt=\"Image Description\" width=\"300\" height=\"600\">
</div>
</section>
</body>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}