import Foundation
let pattern = #"<!--(.*?)-->|\s\B"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<body>
<!-- carousel slider section -->
<section id="carousel">
<div class="carouserl-item" id="carousel1">
<!-- gambar pertama -->
<img src="img1.jpg" alt="Image Description" width="300" height="600">
</div>
<div class="carouserl-item" id="carousel2">
<!-- gambar kedua -->
<img src="img2.jpg" alt="Image Description" width="300" height="600">
</div>
</section>
</body>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)