import Foundation
let pattern = #"-{9,}\W*((?:(?!-{9}).)*?)- \[\d+]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"---------Some text is here.---------More text is here - [3548]----- Even more text is here.-----------More text is here - [408]--------- Even more text is here again."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" \1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)