use strict;
my $str = '---------Some text is here.---------More text is here - [3548]----- Even more text is here.-----------More text is here - [408]--------- Even more text is here again.
-----------------------More text; is here - [3548]';
my $regex = qr/-{9,}(?:(?!-{9}).)*?- \[\d+]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";