#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[-+]?(?:\.[0-9]+|[0-9]+(?:\.[0-9]*)?)(?:[eE][-+]?[0-9]+)?$"
Local $sString = "0.0001" & @CRLF & _
"-5" & @CRLF & _
"0.3425" & @CRLF & _
"1e-4" & @CRLF & _
"1E-4" & @CRLF & _
"-4.34" & @CRLF & _
"5." & @CRLF & _
".5" & @CRLF & _
"-.5" & @CRLF & _
"+5" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"1Ee-4" & @CRLF & _
"Test123" & @CRLF & _
"+-2" & @CRLF & _
"." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")