#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)search-service_1 \| sms res id = (\d+) , distance = {{{} \[\] \[\] <nil>} 0 \[\] (.*) <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}"
Local $sString = "search-service_1 | sms res id = 45814 , distance = {{{} [] [] <nil>} 0 [] 4.5 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 18622669 , distance = {{{} [] [] <nil>} 0 [] 3.5 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 18541500 , distance = {{{} [] [] <nil>} 0 [] 2.7 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 17806946 , distance = {{{} [] [] <nil>} 0 [] 4.9 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 18645390 , distance = {{{} [] [] <nil>} 0 [] 4.2 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 47573 , distance = {{{} [] [] <nil>} 0 [] 3 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 18388659 , distance = {{{} [] [] <nil>} 0 [] 430 m <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 18605401 , distance = {{{} [] [] <nil>} 0 [] 2.4 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 47291 , distance = {{{} [] [] <nil>} 0 [] 3 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 48192 , distance = {{{} [] [] <nil>} 0 [] 640 m <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 41059 , distance = {{{} [] [] <nil>} 0 [] 4.5 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 41863 , distance = {{{} [] [] <nil>} 0 [] 1 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 42077 , distance = {{{} [] [] <nil>} 0 [] 5.3 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 18946571 , distance = {{{} [] [] <nil>} 0 [] 1.7 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 44398 , distance = {{{} [] [] <nil>} 0 [] 1.7 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 45025 , distance = {{{} [] [] <nil>} 0 [] 5.3 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 41338 , distance = {{{} [] [] <nil>} 0 [] 4.2 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 41847 , distance = {{{} [] [] <nil>} 0 [] 4.2 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 42129 , distance = {{{} [] [] <nil>} 0 [] 5.3 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 41065 , distance = {{{} [] [] <nil>} 0 [] 4 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 41835 , distance = {{{} [] [] <nil>} 0 [] 3.3 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 43315 , distance = {{{} [] [] <nil>} 0 [] 4.2 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 43171 , distance = {{{} [] [] <nil>} 0 [] 1.1 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 41083 , distance = {{{} [] [] <nil>} 0 [] 4.8 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 41096 , distance = {{{} [] [] <nil>} 0 [] 670 m <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 44809 , distance = {{{} [] [] <nil>} 0 [] 3.8 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 46066 , distance = {{{} [] [] <nil>} 0 [] 1.4 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 32941 , distance = {{{} [] [] <nil>} 0 [] 4.3 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 44365 , distance = {{{} [] [] <nil>} 0 [] 1.5 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 35267 , distance = {{{} [] [] <nil>} 0 [] 1.6 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 18357376 , distance = {{{} [] [] <nil>} 0 [] 4.6 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 18372032 , distance = {{{} [] [] <nil>} 0 [] 430 m <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 18358464 , distance = {{{} [] [] <nil>} 0 [] 3 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 35973 , distance = {{{} [] [] <nil>} 0 [] 4.6 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 44255 , distance = {{{} [] [] <nil>} 0 [] 4.9 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 44338 , distance = {{{} [] [] <nil>} 0 [] 5.3 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 44419 , distance = {{{} [] [] <nil>} 0 [] 1.1 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 47632 , distance = {{{} [] [] <nil>} 0 [] 1.6 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 47555 , distance = {{{} [] [] <nil>} 0 [] 3 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 47626 , distance = {{{} [] [] <nil>} 0 [] 3 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 47805 , distance = {{{} [] [] <nil>} 0 [] 1.3 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 47798 , distance = {{{} [] [] <nil>} 0 [] 3.9 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 48097 , distance = {{{} [] [] <nil>} 0 [] 3 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 48503 , distance = {{{} [] [] <nil>} 0 [] 440 m <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 47011 , distance = {{{} [] [] <nil>} 0 [] 3 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 47066 , distance = {{{} [] [] <nil>} 0 [] 4.2 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 18476898 , distance = {{{} [] [] <nil>} 0 [] 930 m <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 18466014 , distance = {{{} [] [] <nil>} 0 [] 3.6 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 18168364 , distance = {{{} [] [] <nil>} 0 [] 1.6 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 18466032 , distance = {{{} [] [] <nil>} 0 [] 3.8 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 18426898 , distance = {{{} [] [] <nil>} 0 [] 3.8 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 17754652 , distance = {{{} [] [] <nil>} 0 [] 3.8 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 17871402 , distance = {{{} [] [] <nil>} 0 [] 1.4 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 16542271 , distance = {{{} [] [] <nil>} 0 [] 1.7 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 16557043 , distance = {{{} [] [] <nil>} 0 [] 5.4 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 16529631 , distance = {{{} [] [] <nil>} 0 [] 4.9 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 17740628 , distance = {{{} [] [] <nil>} 0 [] 2.5 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 17741763 , distance = {{{} [] [] <nil>} 0 [] 3.9 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 17715215 , distance = {{{} [] [] <nil>} 0 [] 4.8 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}" & @CRLF & _
"search-service_1 | sms res id = 17740619 , distance = {{{} [] [] <nil>} 0 [] 4.2 km <nil> <nil> <nil> <nil> unknown 0 0 0 <nil> 0}"
Local $sSubst = "$1, $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)