package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(rpm)\s?\d+|\d+\s?(?1)`)
var str = `hotpoint nm11 823 wk eu n 1200 rpm 8 kg class a+++
hotpoint nm11 823 wk eu n rpm 1200 8 kg class a+++
hotpoint nm11 823 wk eu n rpm1200 8 kg class a+++`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}