re = /\shref=(["'])(.*?)\1/
str = '<ul>
<li><a href="/page/">pag2 </a></li><li><a href="/page/">pag2 </a></li><li><a href="/page/">pag2 </a></li>
</ul>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end