#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.{10,})(?=.*[A-Z].*)(?=.*[a-z].*)(?=.*\d.*)(?=.*[\!\@\#\$\%\^\&\*].*)(?=^[\!\@\#\$\%\^\&\*a-zA-Z0-9]+$)^.*$"
Local $sString = "n0capitals!" & @CRLF & _
"NoNumbers!" & @CRLF & _
"NOL0WERCASE!" & @CRLF & _
"N0symbolss" & @CRLF & _
"TooS#0rt!" & @CRLF & _
"B4dcharac+er!" & @CRLF & _
"" & @CRLF & _
"Passw0rd1!" & @CRLF & _
"" & @CRLF & _
"longerPassw0rd2!" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")