const regex = /(\..+?,)+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\..+?,)+', '')
const str = `1805161703530.jpg,1805161703531.jpg,1805161703532.jpg,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}