#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!^foo$)^\w+$"
Local $sString = "foo" & @CRLF & _
"foobar" & @CRLF & _
"food" & @CRLF & _
"like" & @CRLF & _
"many" & @CRLF & _
"times" & @CRLF & _
"fun" & @CRLF & _
"plan" & @CRLF & _
"things" & @CRLF & _
"stuff" & @CRLF & _
"wins" & @CRLF & _
"foo" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")