use strict;
my $str = '123.00 USD
1234 USD
357.0 USD
456 00 USD
651USD
753.684 USD
123 456 USD
-123 USD
789.00 XXX
123.00 wrongcurrency
test string
$159';
my $regex = qr/\b(\d+)(?:(?:[\.\s]0+|(\.\d+)))?\s?USD/p;
my $subst = '$\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";