use strict;
my $str = '"index.html" // Correct
"/index." // Correct
//Below Correct
<link rel="icon" type="image/png" href="assets/icon/favicon.png">
<link rel="icon" type="image/png" href=\'assets/icon/favicon.png">
\'/somedir/test.js\' // Correct
<meta name="viewport" content="viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no"> // Correct
Fails Below!!
<script type="text/javascript" src="runtime.js"></script><script type="text/javascript" src="polyfills.js"></script><script type="text/javascript" src="styles.js"></script><script type="text/javascript" src="cordova.js"></script><script type="text/javascript" src="vendor.js"></script><script type="text/javascript" src="main.js"></script></body>
';
my $regex = qr/(\"|')([^"|'|\s]|\\"*)*\..*(\"|')/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}