re = /(\"|')([^"|'|\s]|\\"*)*\..*(\"|')/m
str = '"index.html" // Correct
"/index." // Correct
//Below Correct
<link rel="icon" type="image/png" href="assets/icon/favicon.png">
<link rel="icon" type="image/png" href=\'assets/icon/favicon.png">
\'/somedir/test.js\' // Correct
<meta name="viewport" content="viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no"> // Correct
Fails Below!!
<script type="text/javascript" src="runtime.js"></script><script type="text/javascript" src="polyfills.js"></script><script type="text/javascript" src="styles.js"></script><script type="text/javascript" src="cordova.js"></script><script type="text/javascript" src="vendor.js"></script><script type="text/javascript" src="main.js"></script></body>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end