$re = '/<([^>]*)>/m';
$str = 'This is a <sentence> with several words <demarcated> by <brackets>.
New line. Here is a <second> sentence. Glahluahlgghladaljdlhgl<jad>gdhl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);