#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\+|00)?(?:30)?(69\d{8})"
Local $sString = "The mobile phone format i want to extract is 69xxxxxxxx" & @CRLF & _
"The mobile phone formats i come across in the CVs are:" & @CRLF & _
"6900000000" & @CRLF & _
"00306900000000" & @CRLF & _
"+306900000000" & @CRLF & _
"6900000000" & @CRLF & _
"69 xxx xxxxx" & @CRLF & _
"0030 69xxxxxxxx" & @CRLF & _
"+3069xxxxxxxx" & @CRLF & _
"69/xxxx/xxxx"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)