$re = '/^(?!.*event2\b).*$/m';
$str = 'event23,event1,event67=12
event1,event30
event23
event2
event2
event2,event23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);