const regex = /^(?!(\d)\1{10,})(?=.*\d)[A-Za-z0-9]{11}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(\\d)\\1{10,})(?=.*\\d)[A-Za-z0-9]{11}', 'gm')
const str = `90956780083
PR213328112
00000000000
00000000001
0000
123456789
1234
abc123
456456
987654321
3210
çá058
PR 213328112
PR.213328112`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}