$re = '/(5.{0,3})?((A|C|G|T|N|\/|\(|\)){3,})+(.3{0,3}.)?/';
$str = '5\'ACGTACGTAATG\'3
AAAAAAACG
(C/G/T)ACGTG(G/T)(A/C)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);