# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?:(?:https?):\/\/(?:(?:(?:.+\.)?ifiske\.se)|(?:localhost))|(?:ifiske:\/\/.*))(?::\d{1,5})?)$"
test_str = ("#Dessa ska fungera\n"
"ifiske://localhost\n"
"ifiske://notlocalhost\n"
"http://localhost:123\n"
"ifiske://notlocalhost:123\n"
"ifiske://\n"
"http://www.ifiske.se\n"
"https://www.ifiske.se\n"
"http://ifiske.se\n"
"https://ifiske.se\n"
"http://test.ifiske.se:123\n"
"https://abc.ifiske.se\n\n\n"
"#Dessa ska inte fungera\n"
"https://test.inteifiske.se\n"
"inteifiske://test:123\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.