$re = '/\b((?!^\d+)^.*?)\:([a-zA-Z0-9_-]*)\b/m';
$str = '123:12-nov-2021 07:00:00
date123:12-nov-2021 07:00:00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);