package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\-\-\sSTART\n(.+?)\n\-\-\sEND`)
var str = `-- START
CREATE DATABASE IF NOT EXISTS feather_store_dev;
-- END
-- START
CREATE TABLE IF NOT EXISTS feather_store_dev.accounts (
id int,
email varchar(25),
bio varchar(18),
password varchar(32),
PRIMARY KEY (id)
);
-- END`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}