import Foundation
let pattern = #"https://((?:[a-z0-9-]+\.)*)([a-z0-9-]+\.[a-z]+)($|\s|\:\d{1,5})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
# Valid
https://host
https://some.xyz
https://some.other.xyz
https://some.other.one.xyz
https://my.abc.example-domain.xyz:443
https://my.abc.example-domain.xyz
# Invalid
https://my.abc.example-domain.xyz
https://my.abc.ex|am|ple-|dom|ain|.xyz:443
https://éhééé.fr
https://invalid domain.fr
https://invalid domain
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)