#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^NEVPT2.*\n(?:(?!end$).*\n)*end$"
Local $sString = "JOB 1" & @CRLF & _
"CASSCF RESULTS" & @CRLF & _
"***" & @CRLF & _
"Lots of text" & @CRLF & _
"***" & @CRLF & _
"end" & @CRLF & _
"NEVPT2 RESULTS" & @CRLF & _
"***" & @CRLF & _
"Lots of text" & @CRLF & _
"***" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"JOB 2" & @CRLF & _
"CASSCF RESULTS" & @CRLF & _
"***" & @CRLF & _
"Lots of text" & @CRLF & _
"***" & @CRLF & _
"end" & @CRLF & _
"NEVPT2 RESULTS" & @CRLF & _
"***" & @CRLF & _
"Lots of text" & @CRLF & _
"***" & @CRLF & _
"end" & @CRLF & _
"………………" & @CRLF & _
"JOB 31" & @CRLF & _
"CASSCF RESULTS" & @CRLF & _
"***" & @CRLF & _
"Lots of text" & @CRLF & _
"***" & @CRLF & _
"end" & @CRLF & _
"NEVPT2 RESULTS" & @CRLF & _
"***" & @CRLF & _
"Lots of text" & @CRLF & _
"***" & @CRLF & _
"end"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")