#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)=\s?.*(?:((?i)Fields\("(\w+)"\)\.Value\)*?))"
Local $sString = "Function lmpRoundedEndTime_ValueChanged(sender, e)" & @CRLF & _
"If CDbl(Fields("lmpShiftID").Value) <> 0 And IsNull(Fields("lmpRoundedStartTime").Value) = False And IsNull(Fields("lmpRoundedEndTime").Value) = False Then" & @CRLF & _
" If CInt(App.Props("PN").Fields("xapDCPayCalculationMethod").Value) <> 2 Then" & @CRLF & _
" Fields("lmpPayrollHours").Value = App.Ax("TimecardFunctions").CalculateHours(Fields("lmpShiftID").Value,Fields("lmpRoundedStartTime").Value,Fields("lmpRoundedEndTime").Value)" & @CRLF & _
"'''''''''''' ^ above should capture: lmpShiftID , lmpRoundedStartTime , lmpRoundedEndTime" & @CRLF & _
" End If" & @CRLF & _
"End If" & @CRLF & _
"End Function" & @CRLF & _
"" & @CRLF & _
"Function TimecardLines_SetDefaultValues(sender, e)" & @CRLF & _
" Dim oRs,dTimecardDate" & @CRLF & _
" dTimecardDate = Null" & @CRLF & _
" Set oRs = CreateObject("ADODB.Recordset")" & @CRLF & _
" oRs.Open "select lmpEmployeeID,lmpShiftID,lmpTimecardDate,lmpProjectID from Timecards where lmpTimecardID = " + App.Convert.NumberToSql(Fields("lmlTimecardID").Value),Connection,adOpenStatic,adLockReadOnly,adCmdText" & @CRLF & _
" If oRs.EOF = False Then" & @CRLF & _
" Fields("lmlEmployeeID").Value = oRs.Fields("lmpEmployeeID").Value" & @CRLF & _
" Fields("lmlShiftID").Value = oRs.Fields("lmpShiftID").Value" & @CRLF & _
" Fields("lmlProjectID").Value = oRs.Fields("lmpProjectID").Value" & @CRLF & _
" dTimecardDate = oRs.Fields("lmpTimecardDate").Value" & @CRLF & _
" End If" & @CRLF & _
" oRs.Close" & @CRLF & _
" " & @CRLF & _
" oRs.Open "select top 1 lmlRoundedEndTime From TimecardLines Where lmlTimecardID = " + App.Convert.NumberToSql(Fields("lmlTimecardID").Value) + " Order By lmlRoundedEndTime Desc",Connection,adOpenStatic,adLockReadOnly,adCmdText" & @CRLF & _
" If oRs.EOF = False Then" & @CRLF & _
" Fields("lmlRoundedStartTime").Value = oRs.Fields("lmlRoundedEndTime").Value" & @CRLF & _
" Else" & @CRLF & _
" Fields("lmlRoundedStartTime").Value = App.Ax("Shift").GetDayStartTime(Fields("lmlShiftID").Value, dTimecardDate, e.SqlTransaction)" & @CRLF & _
" ' Added to to fix -rounded end time is earlier than the rounded start time error when changing the labor hours" & @CRLF & _
" 'Fields("lmlRoundedEndTime").Value=Fields("lmlRoundedStartTime").Value " & @CRLF & _
" " & @CRLF & _
" End If" & @CRLF & _
" oRs.Close" & @CRLF & _
"" & @CRLF & _
" If Trim(Fields("lmlEmployeeID").Value) <> "" Then" & @CRLF & _
" oRs.Open "select lmeDirectExpenseID,lmeIndirectExpenseID,lmeDefaultWorkCenterID from Employees where lmeEmployeeID = " + App.Convert.StringToSql(Fields("lmlEmployeeID").Value),Connection,adOpenStatic,adLockReadOnly,adCmdText" & @CRLF & _
" If oRs.EOF = False Then" & @CRLF & _
" If CInt(Fields("lmlTimecardType").Value) = 1 Then" & @CRLF & _
" If Trim(oRs.Fields("lmeDirectExpenseID").Value) <> "" Then" & @CRLF & _
" Fields("lmlExpenseID").Value = oRs.Fields("lmeDirectExpenseID").Value" & @CRLF & _
" End If" & @CRLF & _
" Else" & @CRLF & _
" If Trim(oRs.Fields("lmeIndirectExpenseID").Value) <> "" Then" & @CRLF & _
" Fields("lmlExpenseID").Value = oRs.Fields("lmeIndirectExpenseID").Value" & @CRLF & _
" End If" & @CRLF & _
" End If" & @CRLF & _
" If CInt(Fields("lmlTimecardType").Value) = 2 Then" & @CRLF & _
" If Trim(oRs.FIelds("lmeDefaultWorkCenterID").Value) <> "" Then" & @CRLF & _
" Fields("lmlWorkCenterID").Value = oRs.FIelds("lmeDefaultWorkCenterID").Value" & @CRLF & _
" End If" & @CRLF & _
" End If" & @CRLF & _
" End If" & @CRLF & _
" oRs.Close" & @CRLF & _
" End If" & @CRLF & _
"End Function"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")