// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"id":(\d+),.*"#).unwrap();
let string = "{\"data\":[{\"id\":1,\"description\":\"Test description 1\", \"Location\": \"test location 1\"}, {\"id\":2,\"description\":\"Test description 2\", \"Location\": \"test location 2\"}, {\"id\":3,\"description\":\"Test description 3\", \"Location\": \"test location 3\"}]}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}