use strict;
my $str = '2018-09-03 15:01:58,384 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 24.178 seconds
2018-09-03 15:01:59,934 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BSK270M1-11
2018-09-03 15:01:59,934 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: ERACK
2018-09-03 15:02:21,873 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 21.952 seconds
2018-09-03 15:06:52,873 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BSK270M1-16
2018-09-03 15:06:52,873 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: ERACK
2018-09-03 15:07:27,960 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 35.298 seconds
2018-09-03 15:10:16,361 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BPRD26-1
2018-09-03 15:10:16,361 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: TOOL
2018-09-03 15:10:41,524 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 25.179 seconds
2018-09-03 15:14:42,750 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BSK270M1-1
2018-09-03 15:14:42,750 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: ERACK
2018-09-03 15:15:06,262 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 23.523 seconds
2018-09-03 15:17:25,399 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BSK270M1-6
2018-09-03 15:17:25,399 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: ERACK
2018-09-03 15:17:46,641 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 21.258 seconds
2018-09-03 15:21:22,709 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BSK270M1-2
2018-09-03 15:21:22,709 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: ERACK
2018-09-03 15:21:43,892 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 21.194 seconds
2018-09-03 15:26:42,393 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BSK270M1-7
2018-09-03 15:26:42,393 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: ERACK
2018-09-03 15:27:06,475 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] PickTask: Cycle Time: 24.093 seconds
2018-09-03 15:28:29,608 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Name: BSK270M1-5
2018-09-03 15:28:29,608 INFO [...PickTask@KMR200_6_Semiconductor_Fab_200] Target Type: ERACK
';
my $regex = qr/(?'DateTime'\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}).*Target Name: (?'TargetName'\w+\-\w+)\n.*Target Type\: (?'TargetType'\w+)\n.*Cycle Time: (?'CycleTime'\d+.\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}