const regex = /^(?:religion = (.*)|\d+(?:\.\d+){2} = {([^}]*)})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:religion = (.*)|\\d+(?:\\.\\d+){2} = {([^}]*)})', 'gm')
const str = `# 1 - Vestisland
# County Title
title = c_vestisland
# Settlements
max_settlements = 2
b_reykjavik = tribal
#b_alftanes = city
#b_skalholt = temple
#b_pingvellir = castle
#b_kjalarnes = castle
#b_hvamm = castle
#b_hlidarendi = castle
#b_borg = castle
# Misc
culture = norse
religion = zoroastrian
terrain = arctic
# History
867.1.1 = {
b_reykjavik = tb_shipyard_1
}
900.1.1 = {
b_reykjavik = castle
b_reykjavik = ca_shipyard_1
b_alftanes = city
}
1000.1.1 = {
culture = norwegian
religion = zoroastrian = sunni = catholic
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}