re = /^(?=.*([a-zA-Z])[a-zA-Z]\1)[a-zA-Z .]+$/m
str = 'goingforeyecheckup
nan means not a number.
do not match her
match here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end