$re = '/\{[0-9]*[^0-9}][^}]*}/m';
$str = 'something {34dj 4s} and something else {335} and more {dgw} and {6} or whatever';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);