$re = '/\[\[(([A-Za-zÀ-ú0-9_.]{1,}?)\.)([A-Za-z0-9À-ú_]{1,}?)\]\]/m';
$str = '[[0_Th.corpus.à_la_findu_monde_et_avant]]
[[0_Th.res.corpus.été_indien]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);