re = /\w*[@]\w+[.]\w{0,4}/m
str = 'harsh@gmail.com
rahultrivedi180@gmail.com
lol@.com
hello.com
@.com
rahultrivedi180@hotmail.com
glsica.org
glsica@gmail.com
rrhul_@yahoo.in'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end