using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[^]\\]*(?:\\.[^]\\]*)*\]";
string input = @"[abc]
[1-9\n\t]
[ \t\]]
[\\\]]
[[\\\\\\\]]
The square brackets cannot be nested, by example in [[]], we want to match [[].
Although, since a \] indicate an escaped bracket, we need to skip those. But a pattern such as \\] must be accepted. The following would not be matched.
[\]
[\\\]
[abc\\\]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}