package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[[^]\\]*(?:\\.[^]\\]*)*\]`)
var str = `[abc]
[1-9\n\t]
[ \t\]]
[\\\]]
[[\\\\\\\]]
The square brackets cannot be nested, by example in [[]], we want to match [[].
Although, since a \] indicate an escaped bracket, we need to skip those. But a pattern such as \\] must be accepted. The following would not be matched.
[\]
[\\\]
[abc\\\]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}